Opened 10 years ago

Closed 9 years ago

#204 closed defect (fixed)

false positive test failure in test_logging.Dumper.test_oops_furl on Windows

Reported by: davidsarah Owned by: davidsarah
Priority: minor Milestone: 0.6.5
Component: unknown Version: 0.6.4
Keywords: test windows Cc:

Description

[FAIL]
Traceback (most recent call last):
  File "c:\tahoe\foolscap\foolscap\test\test_logging.py", line 1908, in test_oop
s_furl
    self.failUnlessEqual(err, "Error: logging/Dumper/oops_furl/logport.furl appe
ars to be a FURL file.\nPerhaps you meant to run 'flogtool tail' instead of 'flo
gtool dump'?\n")
  File "c:\Python27\lib\site-packages\twisted-12.2.0-py2.7-win32.egg\twisted\tri
al\unittest.py", line 271, in assertEqual
    % (msg, pformat(first), pformat(second)))
twisted.trial.unittest.FailTest: not equal:
a = "Error: logging/Dumper/oops_furl\\logport.furl appears to be a FURL file.\nP
erhaps you meant to run 'flogtool tail' instead of 'flogtool dump'?\n"
b = "Error: logging/Dumper/oops_furl/logport.furl appears to be a FURL file.\nPe
rhaps you meant to run 'flogtool tail' instead of 'flogtool dump'?\n"


foolscap.test.test_logging.Dumper.test_oops_furl
-------------------------------------------------------------------------------

This appears to be a false positive due to \ instead of / in the error message.

Change History (3)

comment:1 Changed 10 years ago by davidsarah

Owner: set to davidsarah
Priority: majorminor
Status: newassigned

comment:2 Changed 10 years ago by Brian Warner

Milestone: undecided0.6.5

Should be fixed in [bb43ac5]. Could you confirm?

comment:3 Changed 9 years ago by davidsarah

Keywords: windows added
Resolution: fixed
Status: assignedclosed

Yes, confirmed.

Note: See TracTickets for help on using tickets.